FTP error: 425 LIST Command not working

Every time I try to FTP into my client’s Cloudflare enabled server on Hostinger my FTP programs aren’t able to complete the LIST action, and get the following error:

|Response:|425 Can’t open data connection.|
|Error:|Failed to retrieve directory listing|

So I see an empty directory. Then it disconnects.

So far I’ve tried:

  • Changing FTP settings in Filezilla from Passive to Active mode
  • Increasing the port range in Filezilla
  • Doublechecked that Cloudflare has the A FTP record set to ‘DNS only’
  • Turning off all Firewalls on my PC

Is there a port I need to forward on my router or something?

This happens on both my Filezilla and the NppFTP plugin for Notepad++ I use. I tried digging around but couldn’t find a solution that worked. I’m asking here because I’m able to connect to other clients who aren’t using Cloudflare and this issue only started after I turned Cloudflare on in their environment.

Here’s an error log I generated from an ftp test website: Dropbox - ftp-error.txt - Simplify your life

I’m on Windows 10 Home, Netgear router + modem, using Filezilla + Notepad++ with NppFTP plugin

Thank you for any help or guidance you can send my way!

Greetings,

Thank you for asking.

Sounds to me like the hostname is :orange: for the FTP.

May I ask if you are using a hostname like ftp.yourdomain.com which is proxied and set to :orange:? If you have access to your client’s Cloudflare, you could check for this, or else if not, kindly ask him/her to re-check for this to make a small change at his DNS tab of Cloudflare dashboard for his domain name.

If yes, then kindly switch it to :grey: (DNS-only). That way it would work normally.

Otherwise, if you know the hosting/server IP, try connecting directly to the IP instead of using the hostname for the connection “server field” :wink:

And if this does not help, you might want to contact hosting provider for proper FTP configuration.

Nevertheless, did you checked the checkbox to trust this certificate in further connections?
Maybe the SSL certificate expired?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.