Friends say my domain is redirecting too much

I added my domain, and setup the dns, I need the main A record pointing to a certain IP.

So I did that.

It works for me.
but multiple people in different cities in America, say they are getting “too many redirects” error and one did a dns check and said there are multiple A record IP’s owned by cloudflare and banned by “dnsbl.spfbl dot net”…

what can I do about it?

Your base domain (without the www) points to an IP directly (a :grey: record) and therefore does not get the benefits of Cloudflare.

The www record is pointing to Cloudflare, and redirects to itself (which by definition, is an infinite loop). Do you happen to have any page rules set in Cloudflare? Or is your SSL/TLS setting set to Flexible?

1 Like

I had it being proxied, so I turned that off and they said that fixed it.

So, if I want the benefit of CloudFlare, how do I point the domain to the IP I need, while it is pointed directly at Cloudflare by Nameservers?

Also I just set a rule to always use HTTPS.

Is your TLS setting set to Flexible?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.