Frequent 502, disabling cloudflare proxy fixes the problem

Hi all, we have frequent 502 now once I activated cloudflare.
Disabling cloudflare proxy fixes the problem.

Does someone encounter a similar problem? I have no access to the host logs, and I doubt its needed if it works with the proxy disabled

Appreciate your help!

Can you provide the screenshot of the error you are seeing?

You can read more about the solution for this at Troubleshooting Cloudflare 5XX errors · Cloudflare Support docs

Thank you, I did read all the troubleshooting resources and existing threads in the community. I believe it is not something at the host level as without the couldflare proxy enalbed this never happen.