Freenom With Cloudflare always feedback 503

I had a website on GCP

And use ip with port could connect correct.
So I buy a domain on freenom, with domain the website still could connect.

But I want to use cloudflare DNS service and use this tutorial to set the nameservers

The test on cloudflare always give me 503

Use domain to connect will turn to this page
(https://i.imgur.com/11qYwWo.png)

But if I set the nameservers on freenom as default, it will be normal as well.

Did I miss something?

That site returns a 203, then redirects to Freenom, so something seems wrong.

I suggest you use the Overview page here and click “Pause Cloudflare on Site” to see if that will get the site back to normal while you troubleshoot. It takes five minutes for that option to take effect.

Sorry, I couldn’t understand what is Overview page
Could you describe more clear?

Is “Pause Cloudflare on Site” is this button on cloudflare dash board?
page

After I pause, it turn me to http://freenom.link/?k=80808080&_=1604369585

Thanks for reply.

Now that you’re bypassing Cloudflare for website connections, any issues you’re having are with your hosting plan. You’ll need to get help from your website host.

But if I set the Host on freenom like this

The domain and website will work fine.
Just want to know if I set cloudflare wrong.

It sure doesn’t work fine now. Cloudflare can’t fix a broken site.

1 Like

I reset the freenom now, could you try again?

Thank you

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.