Freenom domain is not adding to CloudFlare. DIG shows that the NS & SOA records are valid

About 4 days ago, I registered a free domain from Freenom. I have rarely had trouble with Freenom & CloudFlare in the past, but recently they both have been acting up. I acquired my domain, then tried to add it to CloudFlare. CF thought about it for a while then shot me with a “Failed to look up registrar and hosting information of at this time. Please contact Cloudflare support or try again later.”. “Okay,” I thought… “I should wait a few days to try this again.” It has now been 3 days since I got my domain, and I have verified via dig that my domain’s nameservers and SOA record(s) are indeed valid. I have tried everything I can find on here, but nothing has worked. That’s why I’m opening a thread.

This has been asked and answered many times already, and :search: would give the same answer.

Freenoms whois service is not responding, and Cloudflare need to verify your domain details via whois to add the domain to CF. Freedom need to resolve this issue before their domains can be added to Cloudflare.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.