Free version SSL with Godaddy


#1

I changed the NS on Godaddy, but when I go to the domain name it doesn’t show https? How do I get Godaddy to recognize Cloudflare’s SSL?

Thanks


#2

I called Godaddy, but they do not support any SSL except their own.


#3

Have you tried typing https://www.yourdomain.com in the web browser? What happens if you do?


#4

I get:

Error 502
Bad gateway
Host Error


#5

If your Godaddy origin server is configured to use a valid SSL cert try setting your SSL mode to Full or Full (Strict). The latter is better because it actually checks the cert.


It will make it so that Cloudflare tries to pull stuff from Godaddy using https (port 443) instead of http (port 80).


#6

This topic was automatically closed after 31 days. New replies are no longer allowed.