Free ssl not showing up

Hi community - I have activated the free Cloudflare SSL on my site, changed namesevers etc. but the SSL is not showing up after 3 days. I’ve done this many times in the past without any issues. I have also tried the mixed content fixer plugins recommended without any luck. I have registered the site on Cloudflare and inserted the Cloudfllare API. No luck. Any help will be gratefully received. Site is coolstuffgeek.com (woocommerce store)

Have you changed your Wordpress Settings to https:// ?
Also do you have a SSL Certificate installed on your Server?
A free Let’s Encrypt SSL Certificate would do it.

If you have a SSL Cert on your Server pls set CF SSL Setting to Full (or Full Strict).
What other SSL Setting (in CloudFlare) have you enabled/disabled?

Hi @eguidestream1,

Looks like point 2 in HTTPS not working? Please read me first!.

Enable ‘Always Use HTTPS’.

2 Likes

Hi domjh, thanks so much, site is now secure, It has a small padlock icon as opposed to https://
Is that normal? One more thing… can I now deactivate the mixed content plugin? Hate too many plugins…
Thanks again

No problem! Yes, the padlock is normal. You can try disabling it to see if the site still works. Just depends how the plugin works and if it has fixed everything!

Thanks again for your help!

1 Like

I would advise you to do so.
Also:

  1. if you change from HTTP to HTTPS (at WordPress) pls change the URL also to HTTPS
  2. after this a lot of Links will be still set to http as they got saved like this to the Database. This will often casue problems with HSTS activated!
    2.1 to fix that you will need to make a Backup first!
    2.2 then install Better Search Replace
    2.3 open it and replace all http: with https:
    2.4 please note the trailing “:” !!! DO not miss this!
    2.5 also ignore case sensitive
    2.6 make sure you do have a Backup of your DB
    2.7 now run the command
  3. be happy with your ‘native’ SSL WordPress installation

#EDIT: dont ask me anything, cant post anymore due to some limitations (just 16 Posts for new Users)

Thanks M