Free SSL - Getting Error Message


#1

Hi Guys

I hope someone can help me with this issue.
I have this Free SSL with Cloudflare in a Website. Everything was working until this afternoon but now I am getting this error in Google Chrome ERR_SSL_PROTOCOL_ERROR

Tried in Firefox and Edge as well. It doesn’t work. Cleared cache, history - still it doesn’t work.

Please help.

Thanks in advance.


#2

Firefox shows this error message:
Error code: SSL_ERROR_RX_RECORD_TOO_LONG


#3

Your site currently isn’t going through Cloudlfare, And when I do try to load it via HTTPS, which tells me it doesn’t have a valid SSL certificate on it.

What is your Cloudflare Crypto setting? It’s probably Flexible or Full.


#4

It’s Flexible


#5

Flexible would be appropriate. So your server redirects an HTTP request to HTTPS, but HTTPS is broken. Can you find a way to turn off that HTTPS redirect?


#6

It’s a Wordpress Website.
I can edit Site/Home URL from https:// to http://
Is that what you are wanting me to do?


#7

For now, that would be good. Once you get that working and then switch back to Cloudflare, this plugin should help:


#8

Alright, let me first try editing database. I’ll be back soon


#9

Edited database.
Tried accessing website; wp-admin but still https:// is kind of being forced.
Would you advise me to “Pause Website”


#10

Edited database.
Tried accessing website; wp-admin but still the same error message; https:// is kind of being forced.
Would you advise me to “Pause Website”


#11

You can add the following lines to wp-config.php to set the URL:
define(‘WP_HOME’,‘http://makkarlaw.ca’);
define(‘WP_SITEURL’,‘http://makkarlaw.ca’);


#12

Adding your script to wp-config.php gives error

Parse error: syntax error, unexpected ‘:’ in /home/content/99/10246699/html/makkarlaw/wp-config.php on line 95

And line 95 is the one where I added define script

So still stuck


#13

Try manually typing in the single quotes. Sometimes formatting forum posts turns them into smart quotes.

Let me see if I can paste it back in as plain text:

define('WP_HOME','http://makkarlaw.ca');
define('WP_SITEURL','http://makkarlaw.ca');

#14

This didn’t work either.
Got the same old error this time ERR_SSL_PROTOCOL_ERROR


#15

This didn’t work either.
Got the same old error this time ERR_SSL_PROTOCOL_ERROR


#16

Something on your server is redirecting to HTTPS. It might be in .htaccess, or it could be something at your host.

By any chance, are you using cPanel?


#17

Here’s what I did.
Renamed Plugins folder and I was able to access wp-admin
Renamed back to Plugins
installed CloudFlare Flexible SSL
Site is back as a “Not Secure” site
Should I now change Site/Home URL in Database to https://


#18

Ah, progress! It loads in HTTP. For now, don’t touch anything in Wordpress.

Put it on Cloudflare with Flexible SSL. Also on the Crypto Page, turn on “Always Use HTTPS” and “Automatic HTTPS Rewrites”

Flexible might introduce some hiccups, so next, enable the Flexible SSL plugin.


#19

The (hopefully) final step is to add this to your .htaccess file:

Header always set Content-Security-Policy: upgrade-insecure-requests


#20

In Crypto

Always Use HTTPS and Automatic HTTPS Rewrites - both were already enabled.
Cloudflare Flexible SSL is activated/enabled.
And website is still on as a “Not Secure” site