Free domain from Freenom


#1

cannot add the freenom free site to the cloudflare having issue saying that xxx.com not a registered domain error code 1049. I am getting started don’t know how to setup the dns nameservers.


Code”:1049
Cant use a freenom website...Even though its registered
#2

Let me be the first…What’s the domain?


#3

I’ll take a guess at what the real problem is. It’s really something like xxx.freenom.com you’re trying to add. Cloudflare doesn’t let you add just a subdomain. It has to be its own domain. With its own name servers.


#4

milliondreams.ga yesterday night registered


#5

No it doesn’t I am trying to add my own domain milliondreams.ga


#6

Also it has it’s ownnameserver


#7

I have seen thatin cloud free domains not going to supported from Dec 28 to Jan 2. Is that may be a issue ??


#8

try to set your CF nameservers in management tools > nameservers


#9

You shouldn’t change the nameservers until the domain has been added to the :logo: dashboard.


#10

Also, in this case I am not sure it really is a nameserver issue. It rather seems Cloudflare cant run the whois or gets for some other reason the impression the domain is not registered.

Thats a case for support -> https://support.cloudflare.com/requests/new


#11

Why not? I always do it when registering a new domain, since all the sites in the same account share the same NS (almost always)

The issue is that the domain doesn’t have any NS set: https://www.whatsmydns.net/#NS/milliondreams.ga


#12

@cscharff speculated about that recently -> Failed to lookup registrar and hosting information of h-com.school at this time. (Code: 1110) but I am still not convinced. Anyhow though, worth a try.


#13

From what I see the domain is resolved directly by the ga root TLD:

$ nslookup -type=soa milliondreams.ga

Non-authoritative answer:
*** Can't find milliondreams.ga: No answer

Authoritative answers can be found from:
ga
        origin = a.ns.ga
        mail addr = cctldga-tech.nic.ga
        serial = 1546256611
        refresh = 10800
        retry = 3600
        expire = 604800
        minimum = 5

When using external NS, it should be instead:

$ nslookup -type=soa fete.ga

Non-authoritative answer:
fete.ga
        origin = chin.ns.cloudflare.com
        mail addr = dns.cloudflare.com
        serial = 2029137617
        refresh = 10000
        retry = 2400
        expire = 604800
        minimum = 3600

Authoritative answers can be found from:

I think that’s because he’s using it in the “forward url” mode, so they don’t set a NS for the second-level domain, and CloudFlare thinks it’s not registered (even if the A record is resolving)


#14

@francesco

From this support article:

Pointing to Cloudflare name servers without signing up the domain first

We never recommend you point to Cloudflare name servers at your registrar or delegate to our name servers without having your domain signed up in your account first. Anyone can sign up domains to Cloudflare and when you point to Cloudflare name servers without claiming the site first, you are effectively opening up DNS control to whomever signs up the domain first on our platform.

The fix here is to sign up the site in your Cloudflare account first and then point to only your Cloudflare assigned name servers after .


#15

Yes ok, in theory it’s right, but if the domain has just been registered nobody has interest to hijack it since it has no traffic… and I would notice immediately when I add the domain in my :logo: account. (the wizard would tell me to change the NS, for example, from ian and lana to john and alan, in the unlikely event someone has already added it to ian and lana)


#16

I just like to try and follow the official guidelines when helping here!! :smile:

It’s entirely up to you what you do with them!


#17

Guys sry for the interruption what should I do finally.


#18

If it still doesn’t work, you will probably need to login to Cloudflare and then contact Cloudflare Support. Unless anyone else has any suggestions, sorry!


#19


#20

You are more expert than me but if the domain has no nameservers I doubt the CloudFlare support can do anything… On the CloudFlare side it’s working as intended IMHO

image