FREE Cloudflare cause site unreachable if proxy is enabled

Sites are unreachable or super slow when DNS proxy is enabled.

I could also not issue a let’s encrypt certificate as it said a AAAA ipv6 address was assigned but my server was not configured for ipv6.

It starts working when I disable all proxy connections in DNS but still not as fast as it used to be. I could also then assign the certificate.

Absolutely have no idea how to even start troubleshooting this. When I bypass Cloudflare then everything works but of course, it’s slow because there is no Cloudflare. Tried every setting on/off on Cloudflare, but I simply cannot find a solution. Spent the last 3 days working on this straight and no solution.

Background:
Been using Free Cloudflare for ages. Got my own dedicated Plesk server about 1 year ago. I have about 8 sites running and have never experienced any issues. Suddenly all my sites are so slow that they timeout. When I bypass Cloudflare everything starts working.

My Plesk server runs on ipv4, never had problems with this in the past. Cannot find any errors on Plesk, and have disabled mod security and fail2ban to make sure that Cloudflare IP’s are not being banned.

I’ve noticed that when I use a VPN for another location in my country, then there is a dramatic speed increase. My IP is not banned anywhere and my ISP is not experiencing any outages.

For starters, what’s the domain?

All domains running on Plesk, here are 3 of them

image

Does not seem to be a Cloudflare issue, you currently paused Cloudflare and coursely.co.za barely loads either. That really seems to be an issue with the site/server.

You could check out Latest Performance Report for: https://coursely.co.za/ | GTmetrix as well. And that actually loaded much faster.

It is NOT paused

In that case the records are unproxied, which is the same.

image

You simply have too many resources and 13 megabytes is not ideal either for a fast site, of course.

Why can I then not issue a let’s encrypt cert when proxied, but it works when not proxied?

I know 13 mb of resources are high, but I never had a problem with that in the past six months. I only started experiencing problems in last 24 hours, and resources has not changed in 6 months.

How is that related to your performance question?

And yes, depending on your configuration, there can be occasionally issues when issuing a certificate as Cloudflare would redirect these requests to HTTPS.

Either disable “Always use HTTPS” or use an Origin certificate.

I’m saying, that there are issues with DNS proxy, when I enable them, it takes more than 10 minutes for the site to load. When I disable them, it takes about 1 minute.

24 hours ago, everything was loading in 10 seconds or less, and there has been no change to Plesk or Websites in over 6 months.

All right, then we are not discussing any SSL certificate issues here, right? We should not mix issues.

There may be plenty of explanations for that, but the underlying issue is that your site is not working properly. No site should take one minute to load and if you fix that, any Cloudflare issues should be fixed along that.

As for Cloudflare, that could have several reasons. Cloudflare connects by default using HTTP 1.1, whereas direct connections will use HTTP 2.0. With your number of resources, that could make a difference. You should be able to change that at https://dash.cloudflare.com/?to=/:account/:zone/network.

Another reason could be some client rate limiting on your server, which limits concurrent connections from Cloudflare.

But the underlying issue really is the site, you need to work on that and make sure the site loads within an adequate period without Cloudflare, then it will work on Cloudflare as well. This is not a Cloudflare issue, but a design one, I am afraid.

Via Cloudflare, the site actually just loaded within a couple of seconds.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.