Fowarding URL rule is not working. Plz help me

I created an fowarding url rule, from non-www to www. Details:

URL: https://mydomain.com/*
Fowarding URL. 301 - Permanent redirect
Destination URL: https://www.mydomain.com/$1

I been waiting for 01 day, but it’s still not working. I dont know what’s the problem here.
Could anyone help me with this? Thank you very much.

Do you have a DNS record for the domain (@)? Use a proxied dummy value of A 192.0.2.1 or AAAA 100:: as you are redirecting all requests.

i turned on proxied for A and AAAA
do i have to type the extract value of this?

Can you show a screenshot of your DNS records?


here you are, i erased the A value for privacy, sr

If you want to use your site as www.weddingplannervn.com then I would suggest…

Change the www CNAME to a proxied A record pointing to the IP address of your site.

Then delete the A and AAAA records for weddingplannervn.com and just add a proxied AAAA record of 100::.

[add]
You also have a DNSSEC issue which will prevent a lot of users from reaching your site…
https://cf.sjr.org.uk/tools/check?2c51f5c0b2694a8dabc9ea692cdd83b4#dns

You need to either disable DNSSEC at your registrar, or enable it at Cloudflare and copy the DS records to your registrar from your dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/dns/settings

This is probably why your original forwarding doesn’t work.


is that correct?

That doesn’t match what I suggested.

You also need to fix the DNSSEC issue.

could you help me with this?

i will contact to the hosting service

:point_down:

You need to contact whoever your domain registrar is (that may be your host or another organisation).


the registrar send me this, they say the website is already signed

could you show me where im wrong with DNS record?

:point_down:

1 Like

done!

now i think the problem is dns record

i solved the problems, thank you so muchhh!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.