Forwarding URL with Page Rule breaks web app (Wildcard)

Dear Community,

I’ve been struggling for days to get the following wildcard Page rule to work.

Page rule:
URL: *
Forwarding Destination:$1

The problem is that it also forwards “www” (CNAME) so it breaks my main website.

Is there a way to get the page rule to ignore the ‘www’ subdomain or is there another solution?

(Extra: I have SSL/TLS encryption mode to “Full”)

Welcome to the Cloudflare Community. :logodrop:

In Page Rules, the first match wins, so you can add a higher priority rule for www. Use a setting that matches your global settings and it should do nothing more than become ineligible to another Page Rule.

1 Like

Thank you so much! I’m not sure what you meant by using a setting that matches my global settings, so I just selected “Always use HTTPS” as the setting. It worked. :muscle:
Thanks again, stranger!


If you already had Always use HTTPS set globally, that’s what I meant. It won’t actually change any setting, but since it matches, it means it won’t be eligible for subsequent rules.

I’m glad to hear it’s working. :partying_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.