Forwarding Rule to Squarespace Blog page not working

My website is at Squarespace. All my domains are using Cloudflare as Registrar and DNS.
Only my main site is connected to Squarespace in the Squarespace portal; however, I do have 2 A records and 2 CNAMEs listed in Cloudflare DNS for all examples.
Only 1 of these domains is not forwarding, despite having the same page rule and DNS entries.

(had to add the ticks in urls)

scarystoriestotellinbusiness.com
– Forwards to – https://www.frameworksconsulting.solutions/scary-stories-to-tell-in-the-boardroom

*scarystoriestotellinbusiness.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.frameworksconsulting.solutions/scary-stories-to-tell-in-the-boardroom)

Success!

scarystoriestotellintheboardroom.com
– Forwards to – https://www.frameworksconsulting.solutions/scary-stories-to-tell-in-the-boardroom

*scarystoriestotellintheboardroom.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.frameworksconsulting.solutions/scary-stories-to-tell-in-the-boardroom)

Success!

frameworksconsortium.com
– Forwards to – https://www.frameworksconsulting.solutions/frameworks-consortium

*frameworksconsortium.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.frameworksconsulting.solutions/frameworks-consortium)

Success!

frameworksforyourbusiness.com
– Forwards to – https://www.frameworksconsulting.solutions/frameworks-for-your-business

*frameworksforyourbusiness.com/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.frameworksconsulting.solutions/frameworks-for-your-business)

Nope!

I’ve tried http:// vs https:// - Didn’t work
I’ve copied the link right off the address bar - Didn’t work

No idea why this particular domain won’t forward.

It works:

# curl -svo /dev/null www.frameworksforyourbusiness.com 2>&1 | egrep "< HTTP|< Location"
< HTTP/1.1 301 Moved Permanently
< Location: https://www.frameworksconsulting.solutions/frameworks-for-your-business

The bigger issue is that your matches don’t have a trailing wildcard, so anybody who tries example.com/index.html will get a 404.

You can also save time by condensing the pairs of them to just one rule: Match *example.com/*

Well, it is taking me to my homepage, but not my Blog page directly.

if Location: https://www.frameworksconsulting.solutions/frameworks-for-your-business isn’t your blog page, then you’ll need to fix that in your rule.

wow, well, something happened and now it is working perfectly!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.