Forwarding old pages (non www) to new site (www)

Hi, I have an URL forwarding problem. I want all non www to forward to www. The CNAME for www works (www.ballsyfoods.com).

Then Rule 3… I want pages (ballsyfoods.com/pages/*) from our old site to forward to the new home page (www). What I have so far from reading the Cloudflare tutorials is:

Currently, Rule 2 - the non www to www isn’t redirecting. https://ballsyfoods.com

I feel like if this part starts working, the 3rd rule will automatically work. What am I missing here that I can’t see? Thank you.
Tom

At first sight, I see cross-rules.

Also may I ask, from what I see, you want to achieve HTTP to HTTPS too, therefore wanting non-www to www too, correct?

And to follow like http non-www /some-page/ (including http www and https non-www to https www) to https www /some-page/?

Maybe you are also missing some DNS record at the DNS tab too.
Kindly, re-check if you have both yourdomain.com and www records at your DNS tab.

  • maybe you are using CNAME or A type …

Furthermore, I believe below articles can help us here:

May I also ask have you got Automatic HTTPS Rewrites option enabled or not?
And also, how about Always Use HTTPS option?
Are they both or one of them being enabled?

Nevertheless, due to redirects and HTTPS, may I also ask which SSL option have you got selected under the SSL/TLS tab of Cloudflare dashboard at your Cloudflare account for your domain name? (Flexible, Full, Full (Strict) …)

1 Like

Thanks for looking! I did follow that article earlier too. I thought I may need HTTP to HTTPS only because the article suggested HSTS Preload List. But I don’t know what that is and I suspect I don’t need it.

I do want the https non-www /some-page/ to https www /some-page/.

Do you see any mistakes with Rules 2 or 3?

I have this as the www CNAME entry.

And the FULL option is selected for the SSL/TLS setting.

And both Automatic HTTPS Rewrites option and Always Use HTTPS options are enabled.

I found one of the issues. The CNAME was Proxied and once I turned that off, it started working.

Now… the last forwarding problem. I want to direct old pages (e.g. ballsyfoods.com/pages/*) to the main home page (ballsyfoods.com).

The rule that’s set up:

It should redirect Not Found page to the home page. But it doesn’t. :frowning:

Any thoughts?
Thanks
Tom

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.