Forwarded domain not forwarding

hi,

we recently migrated our marketing website from vanilla html, css, and js to Forestry and Hugo. we forgot to update a link in our core product to the new privacy page url, so I want to set up a forwarding rule until our next release.

I set the following rule:

*.domain.com/privacy.html -(301)-> https://domain.com/privacy

It has been about 30 minutes at this point and https://www.domain.com/privacy.html still just 404s and doesn’t redirect. What am I doing wrong?

thx

Get rid of the leading dot. Match: *example.com/privacy.html

Actually the leading dot should be fine as the OP seems to specifically address hosts of the domain.

@tech75, can you post a screenshot of your page rules and post the actual domain?

2 Likes

domain is summitsync.com

@sdayman for some reason i can’t reply to your post, so adding as an edit… previously running through Cloudflare proxy really messed with my app, but I just re-enabled the proxy and 301 still doesn’t work.

That server isn’t going through Cloudflare. Do you have its DNS entries set to :orange:?

The naked domain does, but thats still of little use in the mentioned use case.

@tech75, your setup does not reflect your description.

@sandro oic, i updated the www subdomain to use cloudflare proxy and now it works.

Thanks guys!

1 Like