Forward URL Page Rule not working (2 redirects when it should only be 1)

Hi

I’m on the FREE plan.

Right now, it take 2 redirects to go from http://example.com to httpS://www.example.com.

Said another way, http://example.com goes to --> http://www.example.com --> goes to --> https://www.example.com

I want to make this a single redirect (http://example.com to go to httpS://www.example.com)

The only way I know to solve for this is to use the Forward URL Page rule. (If there is another better way, please let me know)

This isn’t working and you can try for yourself on my site. When I look at the network traffic, it still shows 2 redirects for http://example.com

What am I doing wrong?

Thanks in advance.

@sdayman

Unfortunately, both Always Use HTTPS and Automatic HTTPS Rewrites are disabled (as found with SSL/TLS certificates screen).

Any other ideas?

Additionally, does it make a difference that my DNS is hosted with Dreamhost?

Dreamhost has some kind of official Partnership with Cloudflare where my DNS is still hosted with Dreamhost, yet I can use Cloudflare services.

Oh, an external setup. You’re just going to have to bug DreamHost about this. But as I said in the linked post, the double redirect is not a ranking issue, and users should rarely encounter this or be bothered by it.

@sdayman

So if I want to move my DNS to Cloudflare, what name server do I use?

You’d have to turn off that DreamHost Cloudflare setup, then make sure your domain has been removed from your Cloudflare account. Then manually add it here in the Cloudflare dashboard.

This topic was automatically closed after 14 days. New replies are no longer allowed.