Forward a subdomain a different ip

Hi,

I forwarded my main domain to a VPS and it works without any problem.

I’d like to forward a subdomain to another server with a different ip but it doesn’t work, it is always linked to the VPS.

These are my records:

The blue A records are linked to the vps and the red one is linked to the other ip.

What’s wrong?

Thanks

Greetings,

Thank you for asking.

So, on the 1st VPS and on the 2nd server, you have some content? :thinking:
Are they different or the same?

Currently, I get 403 or 404 so far for store.ticinocraft.ch:

  • some kind of Synology in the source code view, are you using it for a NAS maybe? Is the SSL for the NAS configured correctly or? :thinking:

What do you get if you temporary unproxy :grey: (DNS-only) that DNS record? :thinking:
Does it work then?

Have you tried to use “Purge Everything” option from the Cloudflare dashboard → Caching → Configuration?

I wonder if the wildcard * record could cause and be the issue, just guessing :thinking:

And the VPS vhost file of that sub-domain store is configured to return the corelated content for store.domain.com?

May I ask if you are using some Page Rules for it or?

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.