Form Submission Trigger Not Working with Cloudflare Zaraz

Hi Cloudflare Community,

I am experiencing an issue with the Cloudflare Zaraz form submission trigger. Despite following the documentation and verifying all configurations, the trigger does not seem to fire upon form submission.

Details:

Main Domain: golzak.com

  • Subdomain: portal.golzak.com
  • Form ID: contactus_form
  • Zaraz Script: Included and verified on the subdomain

Steps Taken:

  1. Configured Trigger in Zaraz:
  • Where: https://www.golzak.com/websites
  • Trigger Name: Generate Lead
  • Rule Type: Form submission
  • CSS Selector: #contactus_form

Checked Network Requests:

  • No data is being sent to Zaraz upon form submission.
  • Enabled debug mode in Zaraz and saw no relevant debug messages in the console.

Despite these efforts, the trigger still does not fire. We have verified that there are no JavaScript errors and that the form is correctly selected and submitted.

Scroll Depth are not triggered as well on mail domain and being triggered on subdomain.

Could you please help identify what might be going wrong or suggest any additional steps we can take to resolve this issue?

Thank you for your support!

My conclusions is that Zaraz auto-injection on subdomain always had triggers fired while included script on main domain (for no orange cloud domains) is not all firing.

Examples:

Pageview always fires on main domain (no orange cloud)
Scroll Depth not firing (main domain issue or no orange cloud)
CSS Selector not firing (main domain issue or no orange cloud)

Please troubleshot guys the Zaraz on no orange cloud domain.

I cannot use orange Cloud for my main domain since it’s hosted on a SaaS.

Thanks in advance on help.