Forgot to pay for the domain, because of which it did not work for several hours, after that SSL stopped working correctly

Domain connected to Cloudflare.com
I forgot to pay for the domain and it turned off for several hours due to non-payment, after I paid, the domain worked, but SSL from Cloudflare stopped working adequately.
When trying to access the site using the https protocol, it gives an error ERR_SSL_VERSION_OR_CIPHER_MISMATCH (through any browsers, tried from different devices)
And on http everything works correctly.

FireFox does not write in the information about the certificate that it was issued by Cloudflare.
The SSL mode on cf is “flexible”.
No settings (DNS, NS) were changed, only the domain was not paid for for several hours.
I’m using the free version of cf, SSL is also free.

Scroll to the bottom of https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates and click on Disable Universal SSL, give it a minute and then click on Enable Universal SSL.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.