Forced refresh by Ctrl+F5 switching from https to http

I have 3 websites configured identically here on cloudflare. Flexible SSL, always use and rewrite HTTPS.
.htaccess are the same for all 3 websites. No rewrite rule in the .htaccess.

By refreshing the browser (F5) everything is fine: SSL is working.
But, by a forced refresh (Ctrl+F5) one page is connected by SSL but 2 are connected by HTTP. After pressing F5 https is working.
Anyway, everytime a forced refresh is switching to http.

Hi, have you tried cleaning your cache or testing on another browser?
If after that it stills happens, you could share your website address with us so we can try and help.

Hi,

Thanks for your help. I didn’t check developer tools in chrome to see, that mixed content is the problem. It seems to be just a link to a jpg. The stat.jpg is accepted but not the thumbStat.jpg. I don’t understand why? If I delete the link to the thumbStat.jpg, the mixed content problem is solved.

Webpage is theapple-1 (dot) com - sorry, this forum allows me only 2 links in a message.

a class=“gallery-link thumbnail thumb_plus mfp-image margin-bottom-5” href=“https://www.Apple1Registry.com/press/Stat.jpg

img class=“img-responsive” title=“Apple-1 Registry” src=“https://www.Apple1Registry.com/press/thumbStat.jpg” alt=“Apple-1 Registry”

The first one is ok because it is just a link, the second one is the actual image being loaded.

Now this: https://www.apple1registry.com/press/thumbStat.jpg
Seems to redirect to: http://apple1registry.com/press/thumbStat.jpg

Are you the owner of apple1registry.com? If you are, you could fix the redirect there.
If not, maybe upload the image somewhere else.

2 Likes

Thanks a lot. I checked the redirects.
Indeed, it was a rewrite in .htaccess on website apple1registry.com. This website used a let’s encrypt certificate but now everything is done by cloudflare.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.