Force ipv6 access on dns that have ipv4 and ipv6 access - Mikrotik DDNS

Hello everyone, everything good?
I need to monitor my network via hetrixtools and I want to use Cloudflare resources to help me with my dynamic ipv6, because ipv4 is cgnat.

My ipv4 is with cgnat but I ipv6 is public and I can reach it through the internet and it is functional.

My mikrotik already provides DDNS because my ipv6 is dynamic.

The tool Hetrixtools, when trying to resolve my ddns preferentially resolves ipv4 initially so it cannot reach ipv6.

I created a DNS cname only dns (since the monitoring tool hetrixtools is online) pointing to my ddns without success.

I would like to know if I can use CF resources to force requests to ipv6.

It can be using some dns record, or using cf workers, could anyone help me with this issue?

Welcome to the Cloudflare Community. :logodrop:

A CNAME will resolve as the requested record type at the target name if that record type exists. This means that you will still get the unwanted address in the A record if one exists.

If you have your own domain, perhaps you would be better off creating only a AAAA record for your router in your Cloudflare DNS. You could then use something like dudanov/mikrotik-Cloudflare-ddns-scripts to update it.

Remember that you will need to set these records to :grey: DNS Only or you will wind up with both A and AAAA records of the Cloudflare proxy published instead of your actual IPv6 adress. If you need more names, they can be created as CNAMEs.


Thank you very much for your help, I thought I could perform ipv6 targeting only with Cloudflare resources.
I solved my problem with the script adapted to ipv6: github Urata/CloudFlareDDNSIpv6 ; I didn’t use the :dudanov/mikrotik-Cloudflare-ddns-scripts script because I don’t feel safe using my global key.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.