Force HTTPS not working as traffic cannot be sent through Cloudflare

Hi everyone,
I’m having a specific issue with a domain using Cloudflare DNS. I forced HTTPS on the domain but for any reason I can’t change the status of the subdomain as the cloud icon stays greyed out no matter if I click on it.
Subdomain is and origin of the web server on Clickfunnels. Only the url is redirected to an HTTPS one but this handled by Clickfunnels itself. I would like to redirect any http request to https. I have also tried Page Rules but they don’t seem to be effective either.
The problem seems to be the status of the subdomain stuck to “DNS Only”…
This is a free account.

Can anyone point me in the right direction please?

Thanks a lot for your help.

Clickfunnels already uses Cloudflare, so you can’t double-Cloudflare that subdomain.


As for the domain, if I go to the http version, Clickfunnels seems to redirect me to https themselves no matter what path I go to. Can you provide an example where http is not routed to https?

Hi sdayman,

No big deal with that though why all the http requests are served over http but the payment ones. All optin pages stay on http.
And Cloudflare is the recommended configuration by CF to use custom domain names.
In other words, how do you force https for any request sent to CF through Cloudflare?

Thanks for your help.

Hi Judge and thanks for your help.

Root level for the subdomain is handled by a Clickfunnels redirect to an https page. Apart from this one and all the command pages where CF seems to force https, http is served.

I’d like to force https everywhere.

Because that subdomain is handled by Clickfunnels, you would have to force HTTPS over at Clickfunnels.

Thanks for this sdayman, but there is no option on Clickfunnel’s end to force https so I’m stuck now…

How come that if I add another subdomain pointing to another third-party platform (Wolfeo) then I can change the status on Cloudflare and force the traffic through Cloudflare?


You can for other subdomains that are not on CF.

You can force HTTPS by using HSTS in the SSL/TLS settings page. Enable it, and make sure you tell it to include subdomains also.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.