Force https error with Cloudflare,error goes when cloudflare turned off

domain name =9technik.cmom
https://prnt.sc/suj975
so basically whats my problem here.

i have installed lets encrypt SSL and sg optimizer settings are set to force https.
whereas I have also install Cloudflare.

now this is SSL test =https://www.whynopadlock.com/results/cefa1b3c-e0e6-40e8-915f-ca751b18de1e

it still says no force https ,where as I have forced it.
when I disable cloudflare this forced SSL error go away.
can you help me with that ?

1 Like

The non-www host name is not proxied by Cloudflare, but it does redirect to http www. It should redirect to https first.

1 Like

how to do it ?
i cant do it via cloudflare DNS as it says manage it via siteground.
when i go to sitegroun to add cname for michalandmax.com (points to) michalandmax.com.cdn.cloudflare.net,site ground tells me this=https://prnt.sc/su4mvl

1 Like

and ■■■■ service of siteground,trying to explain this from last 12 hours

The whynopadlock warning has a Read More type link that explains how to do this in .htaccess

EDIT: If that doesn’t fix it, it’s much better to do a direct Cloudflare setup, but you’d have to disable the Cloudflare setup at Siteground first.

1 Like

The whynopadlock warning has a Read More type link that explains how to do this in .htaccess

already did that ,really simple ssl also did fixed it.
only disabling cloudflare fix it.

let me disable thru sitground and do it via cloudflare.

This topic was automatically closed after 30 days. New replies are no longer allowed.