Force_get_before_post=1


#1

Hi all,

This is an odd one. I have 4 websites running Cloudflare (all in Wordpress) - suddenly 2 cant log on, i get this - force_get_before_post=1. I think both of these coudflartes, i had to copy this wording:

define('FORCE_SSL_ADMIN', true);
// in some setups HTTP_X_FORWARDED_PROTO might contain 
// a comma-separated list e.g. http,https
// so check for https existence
if (strpos($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') !== false)
       $_SERVER['HTTPS']='on'; 

define('WP_HOME','https://example.com');
 define('WP_SITEURL','https://example.com');
 /* That's all, stop editing! Happy blogging. */

Those 2 websites were fine, but now i cant log on. Would anyone else have this issue? Thank you.


#2

Solved it – I would give this out to others, spent all day sorting this one out……

Im using Cloudflare and w3 total cache, i followed this settings: https://www.mprstudio.com/speed-up-wordpress-w3-total-cache-cloudflare/#cloudflare

Which works great, BUT – i had to go into the Cloudflare website account, “Page Rules”, and turn them off; and then go into the “Caching”; i then had to “Purge Cache” for everything.

Suddenly i could then log on. I even turned all the “Page Rules” back on as well, and the 2 sites now work.

Very odd, but if someone else comes across Cloudflare with the Page Rules, be ready to Purge…………