Force Cloudflare to send https requests to server

According to the tutorial on how to fix the “Too many redirects” problem when setting up Cloudflare, one option is to use the “Always Use HTTPS” to force Cloudflare to use https to communicate with your server:

2. To ensure all requests between the browser and Cloudflare are encrypted, you can use an Always Use HTTPS page rule and that way avoid a redirect loop.

However, that does not appear to be working, as I still get stuck in a loop. Am I misunderstanding the description on that option? I would prefer not turning off the redirects on the server itself, because they are stemming from the fact that in the database the WP_HOME and WP_SITEURL settings are configured for, and if I ever need to pause Cloudflare for whatever reason I will need to go in and re-configure them again. Is there a simple way to have Cloudflare use https when communicating with the server?

Thank you.


PS. The link in that tutorial is outdated and is redirecting to a page with a different structure, so the page title doesn’t match and the url fragment doesn’t cause the page to scroll, someone should probably update that.

The important part is to set Full Strict as encryption mode. If that is not the case, all the other settings are irrelevant, as your site won’t be secure (neither with Flexible nor with Full).

Once you set that, it should work and you can optionally also use Always use HTTPS.

What’s the domain?


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.