Font issue & No padlock


#1

Hi Guys,

I’ve just moved my site over to Cloudflare and it seems there is an issue with missing fonts in the menus. It seems to have stripped out the style.

Also, I’ve also updated all the urls to https but the padlock still doesn’t appear.

Any ideas?

My site is www.webshopmechanic.com

Cheers

Matt


#2
  1. In your Wordpress General Settings, make sure your site’s URL is set to https (not the usual http)
  2. On the Cloudflare Crypto tab, turn on Always Use HTTPS.

#3

Yes, this is a mixed content issue. In addition to what @sdayman suggested you could try enabling Automatic HTTPS Rewrites on the Cloudflare dashboard > Crypto tab.


#4

Thanks Guys. I have actioned these are you suggested.

Does it take some time to update? It looks like the font issue has been fix but no padlock.

FYI - I’m not a techy like you guys so be gentle. :slight_smile:

Matt


#5

If you have a caching plugin for your site, clear that cache.

I also suggest you go to the Cloudflare Caching tab and Purge the cache of All Files.

If you have Shell access on your web server, and are lucky enough to have WP-CLI installed, you can run:
wp search-replace http://webshopmechanic https://webshopmechanic

That will update any URLs you missed. I left off the .com for simplicity, as it’s really the first part that needs to be fixed. The search-replace command will accurately replace exactly what you specify.

p.s. I see you’re running Jetpack. I’ve not used that, so I suspect there’s a bit more work to do. It looks like Jetpack is providing some CDN, which should also be cleared.


#6

Jetpack may be a factor. You might also try re-uploading these images through the wordpress interface:

images


#7

Hi Guys,

I’m still not having much luck here.

I can’t seen anything that references CDN in Jetpack. Do I disable it?

I’ve also uploaded those images @andy suggested.

@sdayman, I have access to my server but can’t see WP-CLI anywhere.

Thanks

Matt


#8

The Jetpack CDN feature is called Photon (just looked it up). See if there’s a way to refresh or disable it.

WP-CLI is just a Linux command ‘wp’ Type that in and see if anything happens. If it’s there, it will probably show you a list of wp commands.


#9

Some of the images I mentioned have been fixed. There is one holding you up, it’s the background image of your contact form - the one with :rocket:

I assume this is part of the wordpress plugin you’re using for this form. I’m not sure if it’s Yoast SEO (I can see that you’re using that plugin), or another plugin that you have installed. There may be settings in that plugin where you can update the image URL.

I’m not familiar with Yoast SEO, but this article states it uses canonical URLs. If it is indeed managing your contact form there should be a way to update the URL from the Yoast settings - bug again, I have not used that plugin.


#10

Hi Guys,

Just wanted to say thanks very much for your help. I sorted that image in the end. It was a little bug with Thrive Architect. All sorted now.

Appreciate it.

Matt