Flexible HTTPS issues with wordpress?


#1

I’m very confused here, I have it active on my wordpress site.

Nameservers are changed and correctly pointing to cloudflare

Security: Medium
SSL: Flexable
Status: Active
Cryto - Universal SSL: Active Cert

I’ve then installed “Really simple SSL” plugin, its not picking up the cert and well the site isn’t https. I’ve tried another plugin “Wordpress HTTPS SSL” and its not working either?

All videos I’m watching on this it works fine for them am I missing something?


#2

Domain?


#3

Woops Visitcarlingford.co


#4

Your site does not go through Cloudflare (:orange: is missing; its set to :grey:) and hits directly your server, where you have a certificate configured, however a self-signed one, hence the error.


#5

How do I go about fixing such a thing?


#6

What thing?


#7

Sorry you say my site does not go through Cloudflare I thought Changing the name servers do that. I don’t fully understand how do I get it to go to to the orange cloud or turn it on?


#8

Changing the name servers only changes the name server. If you want requests to go through Cloudflare you still need to enable proxying by switching the record icons from :grey: to :orange: as pointed out earlier. The support center covers that bit in detail.


#9

Fixed thank you so much I did this maybe 2 years ago and didn’t need to swtich them must be newish. Thanks again.


#10

You dont have to switch them. It is perfectly fine to use Cloudflare just for DNS, it is just an additional option to route everything through Cloudflare. Has pros and cons.


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.