Flexible Certificiate Doesn't work on my Network. Using VPN it Works

ssl

#1

I’m using the Flexible Certificate. When I’m on my network it says, Your connection is not private. If I VPN outside of my network it works fine. I’ve been working on this for hours and installed everything yesterday evening. On whynopadlock.com the cert passes. I’ve renewed my IP on my router and it works for a while then it goes back to, Your connection is not private. Has anyone had this weird issue? The only way I can work on my website is to use VPN and I’m not going to do that all the time. Anyone have a solution?


#2

It’s likely a DNS propagation issue that will work itself out. What’s the domain?


#3

The domain is - https://completepowerwashingstl.com


#4

DNS looks good for it.

If you can open up Dev Tools from your browser (F12 key or Cmd/Opt/i), check the headers to see which IP address it’s going to and some Cloudflare response headers.

You can also try: http://completepowerwashingstl.com/cdn-cgi/trace
That should work if it’s going through Cloudflare.


#5

I tried - http://completepowerwashingstl.com/cdn-cgi/trace .

On my network I received a 404. Why would my network not be retrieving through cloudflare? I’m baffled here. I’ve never had this problem…

VPN received this -

fl=35f235
h=completepowerwashingstl.com
ip=159.65.147.31
ts=1530472158.473
visit_scheme=http
uag=Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.143 Safari/537.36 Vivaldi/1.95.1077.45
colo=SIN
spdy=off
http=http/1.1
loc=IN

Dev Tools Firefox - I see my hosting IP and nothing about cloudflare. This is using http since https does not work on my network.


#6

That’s a DNS issue that’s going to take some time for your ISP to catch up. Or you can just start using 1.1.1.1 for your DNS:
https://1.1.1.1


#7

Ok I’ll keep waiting. Thanks for the DNS 1.1.1.1 idea.