Fix broken Cloudflare WARP install

Hello there! I have run into a problem that I already know the cause of, but am unable to fix it.

I was updating the Cloudflare WARP client today with the newest .msi installer package but due to a power outage during installation, it seems I was left with a broken installation. I tried to uninstall the broken package but was unable to do it from the Control Panel or via the .msi package. I tried reinstalling with the .msi package but I kept getting an error: “The installer ended prematurely due to an unknown error…”

So, I then manually deleted the Cloudflare folder in the installation directory (C:\Program Files) and cleared %TEMP%, and ran the installer again. This time, it worked and WARP was installed but it is not working. I cannot connect to WARP despite switching it on (it always says “Disconnected”). And now, every time I try to uninstall it, the “warp-svc.exe” file starts running with high CPU/mem usage until my PC freezes.

I think it could be fixed by deleting corrupted keys of the previous broken installation of WARP in the Windows Registry, but I don’t know all the key locations I’m supposed to be deleting and/or there are other drivers that need to be uninstalled/reinstalled. Would appreciate some assistance from the community. Cheers!

Here’s the debug info (logs) I have (in zipped folder), if needed: Uploadir - Your Upload Directory

  • The “Account” tab in preferences doesn’t connect.
  • In the “General” tab, Connection, DNS protocol and Connection type are “Unavailable” and Device ID is blank.
  • In the “Connection” tab, the drop-down menu for the DNS protocol option is blank (none of 1.1.1.1 or 1.1.1.1 WARP is working).

UPDATE: Apparently, I think I was wrong. The update itself was broken; I rolled back to a previous version (1.5.461.0; Jul 23, 2021) and it’s working fine now.

3 Likes

Yes I have had the same issue, the newest version of Cloudflare Warp and Windows 11 (and some versions of w10) appear to be incompatible with the latest version of Warp.

could you please put that version somewhere for download? so we all can also downgrade and use it. me also have the same issue

1 Like

Here is a list of all previous versions and updates of Warp for Windows: https://install.appcenter.ms/orgs/cloudflare/apps/1.1.1.1-windows-1/distribution_groups/release

3 Likes

I see @milk has already provided the link; it’s the same from where I downloaded the previous version. By the way, after I rolled back to 1.5.461.0, I saw there was a September update (I think it was a beta version 1.5.something) which I thought would work since the October one was the broken version. It seems I was wrong, since it was broken as well and I had to reinstall again.

Version 1.5.461.0 seems to be the most recent working version for me.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.