Firstmarkservices.com not resolving

I’m using the 1.1.1.1 public DNS. It is unable to resolve the firstmarkservices.com domain as well as any subdomains of firstmarkservices.com. I don’t own the site, I just am not able to access it. Does anybody else have this problem?

I followed the pinned “READ ME” post and have the information below.

Cloudflare help tool: https://Cloudflare-dns.com/help/#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiTm8iLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiTm8iLCJkYXRhY2VudGVyTG9jYXRpb24iOiJBVEwiLCJpc3BOYW1lIjoiQ2xvdWRmbGFyZSIsImlzcEFzbiI6IjEzMzM1In0=
DNSViz: http://dnsviz.net/d/firstmarkservices.com/dnssec/

Microsoft Windows [Version 10.0.17763.615]
© 2018 Microsoft Corporation. All rights reserved.

C:\Users\BitPurity>nslookup firstmarkservices.com 1.1.1.1
Server: one.one.one.one
Address: 1.1.1.1

*** one.one.one.one can’t find firstmarkservices.com: Server failed

C:\Users\BitPurity>nslookup firstmarkservices.com 1.0.0.1
Server: one.one.one.one
Address: 1.0.0.1

*** one.one.one.one can’t find firstmarkservices.com: Server failed

C:\Users\BitPurity>nslookup firstmarkservices.com 8.8.8.8
Server: dns.google
Address: 8.8.8.8

Non-authoritative answer:
Name: firstmarkservices.com
Address: 52.33.231.183

C:\Users\BitPurity>nslookup -class=chaos -type=txt id.server 1.1.1.1
Server: one.one.one.one
Address: 1.1.1.1

Non-authoritative answer:
id.server text =

    "ATL"

C:\Users\BitPurity>nslookup -class=chaos -type=txt id.server 1.0.0.1
Server: one.one.one.one
Address: 1.0.0.1

Non-authoritative answer:
id.server text =

    "ATL"