First test with trycloudflare

I have put Cloudflared on my machine.
Then, I have run the command Cloudflared login, and then, i get a long url.
But what must i do with this url.
If I copy it in a web browser, nothing happens. i am just logged on a page wich asks for a ‘domain’.
For the moment, i just want to test the Cloudflare tunnel argo.

I have also seen that it should be necessary to open a web browser on the Cloudflared host. but I have no web browser on my machine, and it is very difficult to install one.
So, what would be the simplest procedure to go on testing on my machine, if I don’t have a web browser installed on it?

I don’t believe that is the case. It needs to have a web server so you can serve content though.

My machine is a PLC with a very light OS based on Debian.

So, I can install some software, but the memory is limited, and so, there is no web browser.

Isn’t there an other way than using a web browser on the machine itself?

Le mar. 7 mai 2019 à 18:26, cscharff via Cloudflare Community [email protected] a écrit :

As I said, you don’t need to install a web browser on the machine. When you start up the tool it will give you a URL that you can preview the site on, that site can be accessed from any machine.


INFO[0006] +--------------------------------------------------------------+
INFO[0006] | Your free tunnel has started! Visit it: |
INFO[0006] | https: //leaves-age-curriculum-saturday |
INFO[0006] +--------------------------------------------------------------+

The URL to paste in your browser is https://leaves-age-curriculum-saturday in the example above. Yours will be whatever is returned when you start it up.

1 Like


Unfortunately, when I type the command Cloudflared login , I just get this reply :

admin@axcf2152:~$ Cloudflared login

Please open the following URL and log in with your Cloudflare account:

Leave Cloudflared running to download the cert automatically.

INFO[0057] Waiting for login…

INFO[0108] Waiting for login…

I don’t obtain the INFO[0006] that you show in your previous message.

And what would be the command to publish my url?

Hi cscharff.
Now I can see an url.
Ok, I can see an url appear, and it opens this page :slight_smile:

What do I have to do then?
I must select a region? How can I do this? There is no list. what must I type in?

To start a tunnel for the tryCloudflare feature you would use the commands referenced here:

1 Like

Does it exist a version of Cloudflare for armel processor?

I ask if the Cloudflare application exists for a processor type armel.
I tried on my machine, wich is equiped with armel processor, and that doesn’t work.
so, I suppose there is a problem in the version type of the processor, maybe…

I try to use Cloudflare tunnel argo, as described in tryCloudflare website.

sorry, but i don’t understand your question.
On the Cloudflare web site, i found a tryCloudflare link.
So, i decided to test it.
The goal is to create an Cloudflare Tunnel , to make my machine port 8081 available on the web, crossing routers and proxy with no configuration in these devices.
I have understood that Cloudflare Tunnel is made for that.
so, i have installed Cloudflared, as mentionned in the tryCloudflare page.
But it seems that i have no reply from the Cloudflare site, when I send the command Cloudflare -login.
normally, an url should appear, but I get nothing.
This problem is already mentionned in the post : First test with trycloudflare - #4 by cs-cf
And as that doesn’t work, I’m wondering if the problem is not coming from my processor version wich wouldn’t be supported by your application…

Was my question 6/7 clear enough?
Do you need more information,

Cloudflare Tunnel client source code is available on GitHub. You can build from source (actually binaries should be available for different CPU architectures under release tab, but aren’t).

Hi Sandro.
Ok, I can see an url appear, and it opens this page :slight_smile:

What do I have to do then?
I must select a region? How can I do this? There is no list. what must i type in?

I have merged the two topics as they ended up in the same place with a duplicate last post :slightly_smiling_face:

1 Like

Thanks, maybe that will help me to get a concrete answer

This seemed fairly concrete to me :slight_smile:

TryCloudflare - Free Argo Tunnel Tool

Thank you for this link, but I alreday read it, and this is the reason why I created this post.
It seems that after the command Cloudflared login, I should receive a certificate .crt.
But I never reaceiv a such certificate, I never get a reply with the beginning of the line
INFO[0006] +--------------------------------------------------------------+
INFO[0006] | Your free tunnel has started! Visit it: |
The link only opens a page, on wich there is a field to insert something, like a region, or a web site.
But I have no website, I just want to publish my machine on the web for tests.
This works fine with other tools like openport, ngrok, portmap… But they don’t seems to be professional sites. Cloudflare seems to be more professionnal… But really not easy startup. And not easy to get answers in the community.
So, if there is a way to get this certificate, other than waiting for it coming from the web site, please tell me…

Have you tried running the command from the link I provided?

  1. Run the following terminal command to start a free tunnel.

Cloudflared will begin proxying requests to your web server; no additional flags needed.

$ Cloudflared tunnel

The command above will default port 8080, but you can specify a different port with the --url flag

$ Cloudflared tunnel --url localhost:7000

This topic was automatically closed after 31 days. New replies are no longer allowed.