First loading of my website takes 20-30 seconds

dash-dns
dash-crypto
#1

Hello everybody,

I’ve created a wordpress a few weeks ago (OVH server and domain), then decided to use Cloudflare to redirect a subdomain to my shop.

Everything worked as planned concerning the redirection and CDN for my main website.

But I noticed than the first loading of my website was taking a lot of time, like 20-30 seconds. So I performed GTmetrix and SpeedInsight and both were pretty good (97/100 for Insight and 85/100 for metrix). I deduced that it wasn’t an issue of wordpress optimization).

My website was loading whether instantly, or 20-30 seconds without anything happening then instant loading of the website.

I then switched off Cloudflare and went back to OVH servers. And tada, no issue, instant loading anytime.

So I know the issue comes from Cloudflare.

I would need Cloudflare for this subdomain redirection but obviously I can’t allow my website to have a 20-30 seconds first loading.

Do you guys have an idea of where the issue could come from?

Here’s my Cloudflare DNS record (right now I’m not using Cloudflare services):

#2

I am afraid I dont seem to be able to confirm the behaviour you described.

Your site, directly, loads within three to four seconds. When loading your site via Cloudflare I managed to load the entire site in less than two seconds (with cached resources).

image

1 Like
#3

Can we see the timing graph for the page/html? I’d like to know where the bottleneck is. TTFB, download, etc.

#4

Also, it could be that an OVH firewall was blocking/tarpitting cloudflares IPs.

#5

Thank’s @jules and @sandro for your help. So I’ve just switched back to Cloudflare servers and right now the issue is back.

@sandro If I try to load my website from a random instagram profile on mobile, I have again to wait 20-30 seconds before website is finally loading. I’ve tried facebook.com just to check, and instant loading for facebook.com. Same issue with private navigation on firefox or safari.
You can try now that I switched back to Cloudflare, I guess you’ll have to wait 20 seconds for a response.

@jules I don’t know how to show you a timing graph but as I said, it’s not about loading speed. The loading speed of my website is pretty good. It’s about “response from the server” before loading.

Now I join you what I have on OVH, maybe it will help figure out…

#6

Sorry I’m a novice in terms of DNS, CDN, etc. Thank’s for taking the time to help me :roll_eyes::grimacing:

#7

And here’s a last one:

#8

Yep. I want to rule out dns and ssl holdups. So we need that timing chart.
I’m on mobile right now so I can’t show you visually. I’ll do my best from memory. In your browser bring up developer tools. Choose Network. Turn on bypass cache. Select doc. Then reload the Page. Click on the doc loaded into the network panel. On the right you’ll see info about that page. Click on timing. Send us what you see there.

#9

This?

#10

I am afraid I still cant confirm it. I just loaded the page and it appeared within three seconds.

Can you post the output of https://disciplinetofreedom.com/cdn-cgi/trace?

#11

@sandro Yes it’s weird actually because from my private navigation on chrome, it’s loading now without issue.

Here’s the output from Firefox on private nav: (it took 70 seconds to get a response)

#12

It took 70 seconds even for that output?

#13

99ms isn’t bad. It’s probably something on the page. Scripts, maybe even malware.
Did that doc take more than a second to load?

#14

@sandro Yes, that’s the output I’ve got after 70 seconds.
Now, I’ve tried to close my firefox private nav window, without closing Firefox app, then opened back a private nav and try to load my website again --> no issue, instant loading.

The issue comes back IF I close Firefox app completely, open it again and try to load my website.
And it’s the same for Chrome or any other platform.

#15

That would suggest it is not a connectivity issue between Cloudflare and your server, but rather between you and Cloudflare.

Whats the output of this?

ping disciplinetofreedom.com
ping www.disciplinetofreedom.com
nslookup disciplinetofreedom.com
nslookup www.disciplinetofreedom.com
#16

@jules @sandro Ok so here it is, I’ve just tried the developper thing from a different computer (not the same IP), the 70 seconds thing happened:

#17

What about the information I mentioned?

#18

?

#19

The DNS lookup was fast. It’s the Inital Connection that’s borked.

#20

Do you know how could I fix this? It doesn’t happen only to me, it happens from other devices, from other countries, etc.