Firewall rules doesn't work with WP WooCommerce

Hi, how are you?

I am trying to configure firewall rules but they are not working.

I need to receive a postback from my payment gateway. But the firewall is blocking.

See the first screenshot: Screenshot by Lightshot

But I’ve already created a rule in the firewall, but it wasn’t triggered once.

See the second screenshot: Screenshot by Lightshot

However, apparently it is not working.

See the third screenshot (I configured yesterday): Screenshot by Lightshot

I appreciate help with this. Thanks.

May I ask have you checked and do you see any logged Firewall Events being blocked?
If so, you could whitelist / allow the IP(s) of the Payment Gateway for further cases (if they are always the same, for example).

From the screenshot above there is a Service: Bot Fight Mode.

Also, may I ask what is the expression of the 3rd rule JS Challenge?
With the 1st you allow it, but the 3rd one is challengeing it, obviously to me.

Or, otherwise, due to Bot Fight Mode, the AMAZON-AES due to it’s reputation is being suspicious and challenged that way.

Thank you very much for answering.

The first screenshot is the event log, here a fullscreenshot: Screenshot by Lightshot

The second is the rule, here a full screenshot: Screenshot by Lightshot

The third is the activity log… zero! : Screenshot by Lightshot

About the Bot Fight Mode: I understand that was the action the firewall took against the threat.

Sorry, I’m with the Fight Bot Mode enabled, but its not allowing what is set in the rules.

This mode is very strict and can not be overridden. If it is incompatible with your site, you need to turn it off.

Thank you very much!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.