Firewall Rule not being updated through API

I have been trying to Toggle a Firewall Rule on/off via the API.

To summarize:

  • I use the API to successfully read the firewall rule and confirm that it read the rule.
  • I change the Paused member from true to false
  • I “successfully” write the same rule back to CF.

I say “successfully” in quotes because the API clearly reports success, but the API returns the same Unmodified rule as the result, with success being set to true, and no error codes to speak of.

*I then proceed to the dashboard and confirm that the rule was not updated.

I have tried using email/key method as well as creating a Token method and including the token in the API. In both cases, I get the same result: The rule does not get toggled on.

This is particularly difficult to debug because the APIs always indicate success, so there are no error codes to work with…

Can anyone suggest what I might be doing wrong here?

This topic was automatically closed after 30 days. New replies are no longer allowed.