Firewall Rule ip Block not working on mobile device, but working on desktop

Hi Guys.

I set up 1 Firewall Rule like this:

(http.request.full_uri contains “xxx.com/yyyy” and not ip.src in { 1.1.1.1 2.2.2.2 ~~~ }) → Block

When I access this uri on desktop with IP not in the above list, it is blocked. (Shows Error 1020)

But when I access it on a mobile phone, it is not blocked.

It’s very weird.
Does anybody have any idea about this?

Thanks.

Are you accessing pages on mobile via Cloudflare?

Check once by visiting {scheme}{hostname}/cdn-cgi/trace

Thanks user3996.

I checked on mobile that it is using Cloudflare proxy.

I am using Flexible SSL/TLS and Always Use HTTPS.
Is it related to this setting?

Ummm… that shouldn’t be a problem.

This topic was automatically closed after 30 days. New replies are no longer allowed.