Firewall Rule Change Question

I had a firewall rule that blocked access to a website for requests where the country was not in a list of 3 countries (e.g. a, b, c).

I later changed the firewall rule by removing one of the countries (e.g. the list is now a, b).

I’ve tested various computers in country c. Some get access denied, but others are not blocked. Is there some kind of cache that remembers a particular computer and continues to allow access until the cache is cleared? I tried deleting browser cookies on the computer in country c, but it’s still not blocked.

Thanks for your help

Firewall rules should take effect immediately. Was this a “Block”, or was it a Challenge?

It’s possible the computer had the site cached. Did you try a different browser on that computer?

Thanks for the suggestions.

This rule was a Block action.

I just tried Ctrl+F5 on the computer and a different browser. Access was not blocked like I expected. There are other firewall rules, but as far as I can tell they shouldn’t be affecting this case.


I wouldn’t expect so, but if all you did was remove one country from a list, it should still work (famous last words).

Can you post a screenshot of your rules?

When you get blocked you get ray id check in firewall events for that ray id an you will know why is blocked

Thanks for the reply. I did some more testing and don’t think the issue is related to firewall rules. I have a home pc that connects to an office pc through a VPN. Both pcs are in country c.

On the home pc if I’m connected to the VPN then access to the website is not blocked.
When I disconnect from the VPN access is blocked (the rule works correctly).

I’m trying to remember, in there is another setting somewhere in Cloudflare that recognizes my office IP and bypasses the firewall rules?

Yes you can whitelist ip in firewall rules “settings” pane if I remember correctly from top of my head

Thanks. Under Firewall - Tools, I found IP access rules, but there wasn’t a rule for the office IP. I suspect that when I access the site from an office pc, somehow it’s bypassing Cloudflare all together. So maybe this isn’t a Cloudflare issue at all. Thanks for your help, everyone!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.