Firefox image load issue

caching

#1

I’m using Cludflare for years and 2 days ago a big issue with image loading started. Users with Firefox (and Safari also I think) having problems to load images. When I check the specific URL of the image its actually downloading it instead of showing.

When I move to “development mode” - all works fine. So I clear cache and then everything works fine for few hours only.


#2

TS - please post the website that is having issues. Also direct links to a few images.

And check your hotlink settings in cloudflare. Turn that off to see if it makes a difference.

But so far it sounds like mime type issue on your server.


#3

Hey Jules, thanks for the reply.

my website is BIBIB.net
I didn’t change anything on my website, just uploaded new content as usual. The problem just suddenly started and being solved when I clear cache on Cloudflare (or enable development mode). Are you sure its issue on my server?

hotlink was already disabled.


#4

I don’t know where the fault is for sure, but it looks to be an issue with WebP.

In Speed > Polish, uncheck WebP. Then purge the cache and try again.


#5

I’m not a pro so I don’t have Polish enabled.
I’m having a problem right now actually once again. would you like to take a look?


#6

It’s the same problem. Either CloudFlare, or your server, or wordpress, is sending out images with the wrong mime type.

You should set a hosts file on your computer to bypass cloudflare and load your site directly. That will help you determine where the issue is.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.