Files cannot be downloaded in wordpress

I have a problem on my website in wordpress/woocomerce ,
When I try to download a PDF file, I get an error: “disconnect - network error” (this message shows a web browser)
when I disable SSL on Cloudflare the downloads work, but when I enable Full SSL again the problem comes back and on Flexible SSL it doesn’t work as well

would it be possible to help me please?

Strange :thinking:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

You could determine if this behaviour continues even by using a “Pause” option at Cloudflare as follows from below? :thinking:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Re-try with updating.
  5. Upon success, un-pause and continue using Cloudflare.

Before moving to Cloudflare, was your Website working over HTTPS connection?

Before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Make sure site is working as expected without any errors via HTTPS.
  6. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host (firewall, etc.) to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Please, take a note to have HTTPS on WordPress too. Could you also write back if your WordPress is configured with “home_url” and “site_url” in the “Options” and working fine over a HTTPS in a different Web browser just for testing purposes.