FFMPEG SRT - Stream has not started yet

Hi!
1.
I am trying to stream to cloudfare via FFMPEG. This is commandline:

ffmpeg.exe -report -rtbufsize 128M -f dshow -i “video=vMix Video YV12:audio=vMix Audio” -codec:v h264_nvenc -s:v 1920x1080 -pix_fmt:v yuv420p -threads 4 -cbr 1 -bufsize:v 7500k -g:v 100 -preset:v fast -profile:v high -b:v 8000k -maxrate:v 8000k -minrate:v 8000k -codec:a aac -b:a 128k -strict -2 -f mpegts “srt://live.Cloudflare.com:778?passphrase=thatpart&streamid=otherpart”

But when I receive stream on Cloudflare, it says stream has not started yet. What is the problem? Why it does not like my commandline? I tried with VMIX srt stream, it was fine, it worked. But this commandline does not playout video, while its received (showing ingest bitrate and so on).

Can I send multiple audio tracks via SRT to Cloudflare, will they be avaible to play on embed and will they be avaible on recroding - reading this from docs - SRT supports newer video codecs and makes using accessibility features, such as captions and multiple audio tracks, easier. But when reading reddit/forum posts, it says that it is not possible.

Did you just post your whole passphrase to the public?

I spent at least 2 weeks messing with ffmpeg manually and could not get it working with the SRT protocol in Cloudflare. It kind of worked in ffplay but that was pointless.

Sending video from like OBS to Cloudflare works no problem. I did try setting the latency setting because I was on a choppy connection. seems like Cloudflare ignores all that. such a shame (probably just uses the defualt)

PS.
It also works using the srt-livestream app from the github, when you pipe ffmpeg into it