Fastly error: unknown domain. HTTP works but HTTPS doesn't

The error I’m getting when accessing my website ( is
Fastly error: unknown domain: Please check that this domain has been added to a service.

Yesterday was the first time I noticed this, a friend of mine in a different country said that he couldn’t view the page. I eventually found someone else have this problem and they used to see if they have any problems in general. For me, when I use sitemeer and I type in my HTTP URL, it works, but when I use my HTTPS URL it doesn’t, it only shows that it works for a few places, and every other place returns a 500 response

Anywhere I looked, they said that it’ll be okay within 48 hours, but my 48 hours are almost up since I started doing this, and I’m in a bit of a hurry to get my page out. On top of that, now it doesn’t work for me either.
Before, if I tried to access my page, it would work, but now it doesnt

The site is working here and looking at DNSChecker. Try accessing it now from another network, I’m suspecting you’re just accessing an old record from DNS cache

Oh okay, thats weird. Does that mean its stuck like this?
I’m a noob in this realm, when does the old DNS record cache get cleared?

I just tried on 2 different networks but its still showing me the same error.

P.S. I also used Tor just now, and on a lot of connections it works, but on some it just doesn’t work

As you correctly pointed out

it does work for some regions but for most it does not.

Unfortunately that’s a message that comes straight from your host and you will need to clarify that with them. Cloudflare is not involved here I am afraid. It would seems as if your content was not provisioned on all their servers.

For better debugging you might want to pause Cloudflare for now and only unpause it once your site loads everywhere fine on HTTPS.

Oh okay, I really thought It was Cloudflares problem since HTTP works everywhere, only HTTPS doesnt.

By host do you mean the Github Pages, or Namecheap?
I host my page on Github Pages, but I got my domain on Namecheap

Wherever you host your content, not your domain registrar.

Best course of action will really be to pause Cloudflare for now, make sure it loads fine on HTTPS everywhere and only then unpause Cloudflare.

Just wanted to let you all know that it was something to do with Cloudflare, I must’ve set it up wrong.

But its okay, I was being cheap, I shouldve just bought a SSL certificate from Namecheap.
It works now, same configuration as before, just now I’m not using Cloudflare at all.

It can’t have been a Cloudflare issue as that message came straight from your host.

But yes, broken certificates often are an issue and a site generally needs to work on HTTPS before you add it to Cloudflare.

Why you should choose Full Strict, and only Full Strict has more on it.

Yeah, but the whole reason I was trying to use Cloudflare was to get a free SSL certificate.
My intentions was to get my portfolio up for as little money as possible, bought a cheap domain and used GithubPages for hosting.
What I was trying to say was maybe my configuration on Cloudflare was wrong. I don’t see why else it wouldn’t work.
I didn’t change anything else on GithubPages since I stopped using Cloudflare|

Also, I was on Full Strict

I am afraid that’s not how it works. And there are plenty of free certificates out there anyhow.

I am sure if you added your domain back to Cloudflare it will work just fine.

When I searched for free ways of getting SSL certificates, lots of people online said that there are a lot of ways to do that, and that Cloudflare is one of the easiest ways to do it.

Infact, with Couldflare, It did work, but only in some regions, that was my issue.

Yes, unfortunately lots of people have no clue what they are talking about.

The point is you need a working SSL environment on your server before you even think of Cloudflare. Otherwise you have all sorts of issues.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.