Failing to set up Argo Tunnel on Windows 10

Normally I know my way around computers and networking. But I’ve only ever worked on Linux and Macs. This is uncharted territory for me. Please be gentle.

I have now spent more than a week trying to reach an API hosted on a Windows machine (that I can access via TeamViewer), through a subdomain on my Cloudflare site, using cloudflared.exe.

This is my setup:

  1. Domain on Cloudflare: example.com.
  2. API listens on http://localhost:4000 on a Windows 10 Pro machine and responds fine to local GET requests.
  3. I’ve downloaded, unzipped and successfully run “cloudflare.exe --version” on the Windows machine.
  4. I’v successfully logged in and the cert.pem-file downloaded automatically.

Questions:

  1. What’s the deal with origin-ca-pool on Windows? It’s mentioned in several places in the docs that something needs to be done, but I cannot find any information about what needs to be done. Or how.
  2. I cannot even get the “–hello-world” to work.
  3. Should I install some kind of Cloudflare Origin Certificate on the local API server?
  4. Should I enable or disable TLS settings in the Cloudflare dashboard?
  5. Should I manually update the DNS with CNAME- or AAAA-records or does the cloudflared.exe take care of it for me?

The thing is I have tried every possible combination of settings I can think of. I would really appreciate a helpful someone with knowledge of Argo Tunnel and Windows.

Your’s truly