Failed: unable to submit build job

All project builds are failing on Initializing build environment.

The probable cause is reinstall CF pages app in github

I already read same topics or discord, but there is no solution without republish project after deleting.
I want to solve this problem without downtime.(same published url, etc…)

Can anyone help me?


I’m facing same issue. It started with activation of 2FA authentication on gitlab. I removed Cloudflare token from gitlab and set integration once again to force authorization token generation and it worked. Well at least for couple of days, because today i have the same error again on each project. I will turn off 2FA in gitlab and check again.

I’ve checked it once again and it works. Go to gitlab: and remove Cloudflare token. Go back to to Cloudflare → Pages → Create repository → Connect to Gitlab. Once you authorize cf in gitlab you can close wizard and came back to project and fire build again.

1 Like

I’m facing the same issue, deleting Cloudflare pages app in github, and connecting again from create project doesn’t fix the issue.

On my end it is Gitlab not GitHub maybe that’s why it is not working for you. I’m going through this steps quite often like once a week or two and every time it works.