Failed to convert site from Http to Https


#1

Hello, really need some help here.

I have two websites, both use Godday hosted Wordpress, and both use Cloubflare’s free SSL (flexible). But only the 1st website (set up a few months ago) is successfully converted to https://. For the 2nd one I replicated all settings and setups as the 1st one, but it just fails to convert to https:// not matter how I try.

I know it’s difficult to comment on without more specifics, I can disclose that the 1st and successful one is www.winmoreuk.com , and the 2nd and unsuccessful one is www.cuttingshort.com . Perhaps staff from Cloudflare can set the backend settings and advise? Any help would be much appreciated.

Thank you.


#2

cuttingshort works on HTTPS, but has a Mixed Content logo file:
http://www.cuttingshort.com/wp-content/uploads/2019/03/卡丁车logo-180x50.jpg


#3

Hello @sdayman, thank you very much for the advice. I have now removed that image as well as another image I added, what’s left now on the website is a dummy template of Dokan plugin and some other untouched plugins, without any external/internal link added by me.

But the site still only shows under www.cuttingshort.com, cuttingshort.com or http://cuttingshort.com, but not when using https://www.cuttingshort.com or https://cuttingshort.com . When I use https:// the error message is “This site can’t provide a secure connection, www.cuttingshort.com uses an unsupported protocol. ERR_SSL_VERSION_OR_CIPHER_MISMATCH”

What shall I do? Thanks again.


#4

It’s all working for me. You may want to clear or turn off browser cache when testing. :slight_smile:

https://www.ssllabs.com/ssltest/analyze.html?d=www.cuttingshort.com&hideResults=on&latest


#5

Thanks @Withheld , but when I click on https://www.cuttingshort.com or https://cuttingshort.com the website would not open, but show that error message. Are you able to open the site using https:// ?

I must be missing something somewhere, but don’t know where.


#6

You need to clear your browser cache

image


#7

Thanks. I deleted cache and browsing history on Chrome but it still shows error page. Very frustrating.


#8

All I can suggest is your device may be out of date because the site is passing all test, browsers and locations I’m testing with.

What are the results for this test?
https://www.ssllabs.com/ssltest/viewMyClient.html


#9

Can you open your browser’s Developer Tools panel and look at the Network tab for a connection to your website? It should show the IP address you’re reaching. Something like:


#10

@sdayman @Withheld Hello both, thank you so much for your kind help. I realised that the https:// page works fine using 4g, but does not work under my wifi, therefore the problem is with the wifi setting.

I asked my wifi system provider to reboot the wifi and accelerator, and it solved the problem! Thanks again for your help. For non-techie like me it is really stressful when something do not work. You guys are great!


#11

Your welcome. If you don’t mind, can you post the WiFi router make and model just in case someone else has the same issue.


#12

@Withheld The wifi router was from Virgin. The wifi booster was from my wifi system provider, but I don’t know the make of the device.