Failed to communicate with the secure server

A site I host on Dreamhost has been running on Cloudflare via an integration that Dreamhost facilitates. I switched to a standard CF implementation via CF nameservers, and now I’m unable to access a couple of hosts.

One is https://www.staging.evolutionaryherbalism.com, where I get the error

#This site can’t provide a secure connection
www.staging.evolutionaryherbalism.com uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

staging.evolutionaryherbalism.com works correctly.

If the request reaches the origin server (shouldn’t, it’s proxied), it’s redirected to drop the www. I tried implementing that via a Page Rule, but got no change in behavior. Page Rule is now turned off.

Scanning the certificate fails with “Failed to communicate with the secure server”
https://www.ssllabs.com/ssltest/analyze.html?d=www.staging.evolutionaryherbalism.com

1 Like

Thanks. I was worried that it may have been related to subdomain depth :stuck_out_tongue:

This doesn’t sound ideal, but might a workaround be to disable Cloudflare’s SSL and serve SSL directly from the origin’s Let’s Encrypt cert?

I’d avoid www on subdomains, but you can certainly :grey: that entry and not use Cloudflare for that subdomain.

1 Like

That’s actually my goal, but someone had previously left support for www.subdomain enabled, and now there are links to it out there :stuck_out_tongue_closed_eyes:

I don’t want to :grey: the www and expose the origin server, but maybe I can stick it on a different host.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.