Failed to activate Cloudflare (Siteground)

Hi, I want to activate Cloudflare on Siteground, I have changed the custom DNS for siteground in Namespace, but I get the following error:

Failed to activate Cloudflare for xxxxx.xxx . Cloudflare API returned CloudFlare could not detect xxxxx.xxx as a registered domain.

I appreciate your help!

What is the domain name?

Could this help:

Regarding the Cloudflare and Siteground, there are two types of setups with Cloudflare - Full via Cloudflare dashboard directly where you change nameservers to the two the Cloudflare assigns to your domain and Partial Partner offered through a Cloudflare partner where you don’t change to cf nameservers (Siteground example).

I tried it again and it works. Maybe the DNS changes weren’t propagated yet

1 Like

Yep, I am getting the same error message from Siteground. CF does say the nameservers can take up to 72 hours to propagate. Glad to hear it now works. Did you change your nameservers in Siteground or did you leave them be?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.