"Failed - Network error" downloading files from NextCloud

Ever since I switched to Cloudflare, users downloading files from my NextCloud server have been getting the “Failed - Network error” message. My server is set to DNS only. I also read http2 can cause problems with it, would that be the case? I am unable to disable it.
Also read that scrape shield may cause issues, so I disabled it but no still doesn’t work. It works fine to download smaller files, but once they become a couple of gigabytes this issue appears. Afaik it’s for both downloading and uploading.
I also have a jellyfin server which sometimes will kinda stop in a similar fashion until I refresh the page. That server is also DNS only. How would I go about solving this issue? Don’t hesitate to ask if you have any questions
Thank you in advance

This is literally telling me it’s not a Cloudflare issue. If you are DNS only, you are bypassing Cloudflare except for DNS, if the IP returned is correct, you’ll never hit Cloudflare for anything else.

Works fine when accessing it through the IP rather than the domain name

You might have issues in the web server, but if it is actually DNS Only, Cloudflare isn’t doing anything there.

For Free plans, when proxied there is a 100MB limit (goes up to 200MB with Pro) in uploads, so given you are hitting up to 2GB without issues, this confirms you are bypassing CF. You couldn’t get to anything close to that except on a custom Enterprise contract… which I am pretty sure you don’t have.

I see.
This is my config in the dashboard

I still have a noip ddns which I used to have basically a memorable domain name before transitioning to Cloudflare, and that is using https. Works fine, even though it yells about certificates lmao

This is not the place to find support for that… I didn’t need the screenshot, I knew it wasn’t proxied given the info above. Ask on NextCloud communities or somewhere else.

I have never used NextCloud, so can’t help you in any way.

Well, how come the NOIP ddns works fine then?

Can’t tell you, but again, Cloudflare isn’t having anything to do with that, so I can’t help you.

For anyone else, the issue turned out to be nginx proxy manager. The ddns worked fine as it had no reverse proxy.
client_max_body_size 0;
proxy_max_temp_file_size 0;
in the advanced section of the proxy solved it for me, although I have not yet tested how this may impact performance.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.