Fail to lookup registrar

hi everyone here… recently i tried to add my few other website but not success with the error mention below.

Failed to lookup registrar and hosting information of at this time. Please contact Cloudflare Support or try again later.

Below is the list of the domain/site that i’ve tried to add

Can someone assist me on this?
FYI, all the domain is not new. Has been registered long time ago.

I imagine this will be due to point 7

Unfortunately, from my peek in the dashboard for my domain, DNSSEC not even enabled :frowning:

Is this already resolved? I see NS records for Cloudflare on that domain:

% dig +short NS

Previously tried to change nameserver to Cloudflare NS. it was not resolved. So i just change it back to its default nameserver for the time being.

normally we still can add site even nameserver not pointing to Cloudflare yet right?

You should never use Cloudflare nameservers before adding the zone to your account.


Case closed. i am not sure what has been done at my provider side. But yesterday i raised a ticket for this issue. they asked to wait while they are escalate this issue to designated team. Before i got update from them, i just tried it again this morning & all domain/site can now be added in the Cloudflare successfully. Anyway tqvm for all our reply dude… Appreciate it so much :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.