Facing issue with WP Reader

I am raising this topic as advised by the WordPress Community. You can check the message by clicking here.

Issue : My domain arablelife.com not populating under sites on the Right Side in WordPress Reader.

Description :
If you compare between two domains

  1. arablelife.com (Mine)
  2. getdimple.com (Sister’s Domain)

You can see both domains are using same services such as,

  1. Registrar (Cloudflare)
  2. CDN (Cloudflare)
  3. Web hosting (Hostinger)
  4. CMS (WordPress)
  5. Jetpack’s Free Plan

But since some days following issue created with only arablelife.com domain.

When prospecting subscriber searches for domain on WP Reader he should find the domain name under sites tab on the right side (on desktop).
It works perfectly for getdimple.com (Check it by clicking here)
But does not work for arablelife.com (Check it by clicking here)

Tested the following solutions to resolve this issue.

  1. Basic troubleshooting such as (Clearing Caches, Cookies)
  2. Reconnecting Jetpack
  3. Report with WP Community Support (Topic: Can't search one of my website in WP Feed Reader | WordPress.com Forums)
  4. WP Debug Mode

As per the guidance received by the WP Community Support team through this message, I have raised this topic on Cloudlfare to resolve issue.

Please help me with the proper solution.

Thank You!

Is it RSS feed fetcher/reader? :thinking:

If so, then 2 possible ways from my point of view:

  1. whitelist JetPack IP addresses in Security → Tools → IP Access Rules

  2. whitelist your origin host/web server IP address in Security → Tools → IP Access Rules

Since it’s related to the WordPress, I’d suggest you to whitelist your origin host / server / hosting IP address by navigating to the Security → WAF → Tools → IP Access Rules with the action “allow” for your Website and try again.

It knows to happen due to the WordPress using HTTP/1.0 and empty user-agent, therefore while executing WP-Cron or some other related JSON/REST API request via plugin.

Helpful article:

WP Reader is not RSS Feed.

Once you connect your account of wordpress.com to the website having WordPress Engine using Jetpack Plugin, WordPress creates automatic feeds called WP Reader.

When you publish your article it will also publish on WP Reader like a social media handle.

But unlike RSS Reader when you delete post, content still visible on WP reader (Unless refresh).

You can check Arable Life’s WP Reader Feed.

You can access it when clicked. But users can not search same feed on WP Reader by entering domain URL in the search box.

To understand such issue clearly, click the both links below.

WP Feed Search for Get Dimple
WP Feed Search for Arable Life

Issue : Arable Life’s site is not populating under site’s tab (From desktop view)

Both websites having same,

  1. Domain Registrar
  2. Cloudflare SSL
  3. Same plan on Jetpack

In order to resole this issue, I contacted WP support community. You can check our conversation by clicking here.

As per the last message, WP community support redirected me to connect with Cloudflare community support, so I am communicating here with you.

Please read out the communication to understand and help me by resolving this issue.

Thank You!

Regarding the error you get, can you share any information which HTTP code error do you get? :thinking:
Can you share a screenshot of it?

Since you’ve been suggested:

You should see the challenged/blocked firewall events in the firewall events if you navigate to the Cloudflare dashboard → Security → Overview and lookup for Firewall events for the past 24hours or so. Once you find them, click on a particular one to find more details about it (user-agent, IP, HTTP version …).

Could you share some details which service was triggered that blocked you? (Managed Rule something my best guess)

May I ask if you’re using Cloudflare Free plan for that domain(s)? :thinking:
If it is the same WAF rule on your Free plan, then the only way to bypass it if it’s Cloudflare’s issue, is as follows from below steps which I write, unfortunately since we cannot exclude specific Managed WAF rules on a Free plan yet.

Currently, there is no way to bypass it or a workaround as for a zone with a Free plan when we inspect for the Firewall Events, it would show “unknown rule id or could not find ruleset” or that a request is being challenged or blocked via “rule XYZ” and no option to add some exception for Managed WAF Rule. For a higher paid plans such as Pro, the WAF has got an option to add an exception or skip that detection.

Last response from Cloudflare support which I’ve got was as follows:

As an update, our engineering team is looking to rollout the WAF for everyone in Q4 this year. This would allow the free tier users to make use of the override feature in our WAF ruleset to bypass the rules.

More about it:

I haven’t used it.

Thank you for feedback information and pointing me to the relevant links.

I’d still test this by:

  1. Disabling Bot Fight Mode on domain which uses Cloudflare
  2. Disabling Browser Integrity Check
  3. Making sure the Jetpack, WordPress Engine and Origin host IPs are “allowed” across the domains for “fetching the thing” and in Cloudflare for the domain which uses Cloudflare → because maybe some other host or website uses Wordfence on other Website which then blocks the requests somehow
  4. Determine if this behaviour continues even by using a “Pause” option at Cloudflare as follows:
    4.1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
    4.2. The link is in the lower right corner of that page.
    4.3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
    → If yes, then I am afraid we have to troubleshoot this at the origin host/server as Cloudflare isn’t involved into those requests & redirects.

To resolve this issue, I have paused Cloudflare service as of now.

Can you please look into the issue from your side?

The issue is still not resolved.
I tested by pausing Cloudflare.

Check out the latest conversation with WordPress Community support regarding this issue by clicking here.

Facts

  1. Domain registrar is Cloudflare, so can not change NS directly to Hostinger Web-Hosting.
  2. Cloudflare is still in paused state and will be until the problem gets resolved.

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share all the informations on the ticket.
Please, share the ticket number here with us so we could escalate this issue by using the method Support > Contact Support option as described from below:

You might be offered to switch to the new Customer Support Portal and create a ticket

cc

Furthermore, if you have been through all these above suggestion and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that ticket number # here.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.