Facing issue 520 Error while loading my site

yes. i just Pause cloudflare…
because my hosting provider ask me to do that.
but when i try to access my WP Dashboard and try to access any post. it shows me origin error. What to do nexT?

When using the Cloudflare Dashboard, click on SSL/TLS button and what setting are you using? Off, Flexible, Full or Full/Strict?

J

currently I am using Full

It appears that you have an SSL certificate on your server so Full would be the correct setting. Temporarily try “Flexible” and see if your site still throws the error.

Maybe your hosting provider is blocking cloudflare’s IP list? You should send them the link to the list to see if they are blocking any.

J

brother my hosting provider is Namecheap and i asked them. They said they are not blocking Cloudflare IP’s

and also Hosting provider said my site and dashboard working fine on there end

“Full Strict”

Full is still insecure.

In your “DNS” settings, do you have proper A records for your domain and does it point to the proper IPs? I’m assuming when you set up your domain, cloudflare imported your old zone file (dns) properly. But check it. I see two IPs for your domain 75.2.109.121 and 99.83.241.49

bro. I changed it to flexible… Now i see some improvement. Now what to do nexT?

Why would you do something which was already explicitly discussed and advised against?

Set it to Full Strict and only Full Strict.

What do you mean by improvement?

As Sandro pointed out, this situation of using ‘Flexible’ is not ideal and not completely secure. It would appear that the problem is with your encryption certificate (assume that your hosting company Namecheap manages it) and you need to advise them that Cloudflare is unable to connect to your server while using it. Maybe a misconfiguration on their part.

J

To be precise, not secure at all.

Bro when Attached my domain with cloudflare. I done exactly proper settings. But 3 days ago i signed up for Ezoic ad and ezoic auto integrates some setting and from that point my website is not performing well

So before you used Ezoic, everything was working fine with your website with encryption set to “Full”? No 520 errors?

J

yes bro

Well firstly set your encryption back to Full or Full Strict. It would appear that Ezoic requires additional configuration to work behind Cloudflare. I have no experience with Ezoic but I did google it and found a page that gives a basic overview of how to make it work with Cloudflare.

https://support.ezoic.com/kb/article/how-to-integrate-with-ezoic-using-cloudflare

If this is beyond your skillset, I would ask your provider to review or start a new post in the support community here.

J

Are you saying from a security point of view, “off” and “flexible” are identical?

J

Yes, they are, both transfer data via HTTP and have no encryption.

Hello everyone,

Due to the number of 520s being reported in similar circumstances, we are escalating the issue to Cloudflare Support. The original incident should have been resolved and your issue may well be unrelated.

We recommend checking these troubleshooting tips, if you haven’t already.

If you have been through these thoroughly and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that #.

To enable efficient troubleshooting by support, please ensure you include the following on the ticket:

  • example URL(s) where you are seeing the error
  • Ray IDs from the 520 pages
  • output from a traceroute from any impacted user
  • output of example.com/cdn-cgi/trace - replace example.com with the affected domain.
  • Also include two HAR file(s) : one detailing your request with Cloudflare enabled on your website and the other with Cloudflare temporarily disabled - see How do I temporarily deactivate Cloudflare ?
2 Likes

So as part of https://community.cloudflare.com/t/random-520-errors/ we fixed an issue with origins silently ending a keepalive connection that was causing very rare 520 errors.

Thus we recommend testing again - if you still see 520s - make sure you follow the guidance in our community tip here: