Facing issue 520 Error while loading my site

Hello,
This is Hussain and I have an issue with my site Void Bike, while loading or Accessing wp dashboard or any thing doing in dashboard continuously facing an issue Error 520 code. I talked to my Hosting provider after analyzing it they said check Cloudflare. and after paused the cloudflare everything working fine and after enabled it I facing delay in load time and while accessing any functional tab I see 520 error or 521 error. Will some one help me? please?

Is it possible that you origin server somehow has Cloudflare’s IP range (or some) on your firewall/htaccess/webserver block list?

Here is the IP list Cloudflare publishes which you must ensure is not in your blocklist:

Also, ask if your hosting provider is blocking any of the IPs in that list. They might be dropping traffic to your server and you’ll see nothing in your logs.

Also, do you have your TLS/SSL set to FULL or STRICT? Try “Flexible” and see if that makes a difference. If you don’t have an SSL cert on your origin server, you need to use “Flexible”.

Hope this helps.

J

I am sorry, but you couldn’t have given the OP a worse advice. You essentially told him to remove all security from his site.

If he doesn’t have SSL configured on his webserver, settings “FULL” and “STRICT” will not work for him. Trying “Flexible” won’t remove encryption from the browser to Cloudflare, only Cloudflare to his origin server.

J

If he doesn’t have a certificate on his server, this is what he needs to fix first. Breaking his site’s security is not a viable option.

And yes, what you suggested will remove encryption. There are entire tutorials on that.

Please do not mislead users here.

His site appears to be working now.

“Flexible” encrypts traffic between the browser and Cloudflare only.

I agree he should get a self signed certificate and set up encryption from Cloudflare to his origin server but I am not assuming he ever had that set up in the first place.

How is this misleading users?

J

That is still insecure. You need a proper certificate on your server.

I am afraid you are assuming wrong. The OP does appear to have a proper certificate on his server.

Plus he has a proper HTTPS redirect.

curl -I --resolve voidbike.com:80:[IP] http://voidbike.com
HTTP/1.1 301 Moved Permanently
keep-alive: timeout=5, max=100
server: LiteSpeed
location: https://voidbike.com/
x-turbo-charged-by: LiteSpeed

Voilà, not only did you make his site insecure, you broke it entirely because it will have a redirection loop.

Sorry I mean to say Cloudflare Signed Certificate.

Well he hasn’t posted anything yet. Perhaps he would like to weigh in?

J

Yes, an Origin certificate is secure, just as is any other publicly trusted certificate. The point is, if you don’t have a certificate, the solution is not to make your site insecure but rather to properly secure your site and install a certificate on your server.

Sorry for late reply… I was reading your replies. and please tell me in simple words as I am new in this field? :frowning:

I agree with you in a way. I was giving advice so he could narrow down his problem.

His site is working for me just now but before it wasn’t. Not sure what changed. Maybe he was blocking cloudflare’s IPs?

J

Your site was giving me an error 520 before but now is working. Did you change anything in your server config?

J

yes. i just Pause cloudflare…
because my hosting provider ask me to do that.
but when i try to access my WP Dashboard and try to access any post. it shows me origin error. What to do nexT?

When using the Cloudflare Dashboard, click on SSL/TLS button and what setting are you using? Off, Flexible, Full or Full/Strict?

J

currently I am using Full

It appears that you have an SSL certificate on your server so Full would be the correct setting. Temporarily try “Flexible” and see if your site still throws the error.

Maybe your hosting provider is blocking cloudflare’s IP list? You should send them the link to the list to see if they are blocking any.

J

brother my hosting provider is Namecheap and i asked them. They said they are not blocking Cloudflare IP’s

and also Hosting provider said my site and dashboard working fine on there end

“Full Strict”

Full is still insecure.

In your “DNS” settings, do you have proper A records for your domain and does it point to the proper IPs? I’m assuming when you set up your domain, cloudflare imported your old zone file (dns) properly. But check it. I see two IPs for your domain 75.2.109.121 and 99.83.241.49